さらに軽いPuppy linux

 SourceForge.JPのパピーリナックス Precise-571JP 本体 Precise-571JP (日付: 2014-01-18)のisoファイルから、CD-Rを焼きます。
 とりあえずの所、メニューからgpartedを選んで、Moeluntu14.04.1の/sda0を10GBほど、減らしました。

/に8GB(忘れずにBoot flagを設定の事)→sda3(ext4)
swapに2GB(メモリ量1GBの2倍くらい)   →sda4(どうやら、2つのlinuxで一緒に使っているので、あとで、4GBとして統合しました)
を、作ります。インストール時に、どこに作るか聞かれるので、sda3のボタンを押します。

うっかり、Grub4Dosをインストール

 ダメなんです、Moeluntu14.04.1はもともとUbuntu14.04.1のlxdeなんです。このマシンにはPAEが無く、GRUBにforcepaeが無いと動かないのでした。仕方がないので、Ubuntu14.04.1のDVD-Rをいれて、F6ボタンを押して、forcepaeを入力。Live Modeで起ちあがってもらい、boot-repairを以下のようにインストールと実行しました。(boot-repairのPPAは14.04にはまだ対応していないので、sedで書き換えを行うのです。)

$ sudo add-apt-repository ppa:yannubuntu/boot-repair
$ sudo sh -c "sed -i 's/trusty/saucy/g' /etc/apt/sources.list.d/yannubuntu-boot-repair-trusty.list"(14年11月26日以降これはもういりません)
$ sudo apt-get update
$ sudo apt-get install -y boot-repair && boot-repair

 指示通りに、直してみました。ただ、forcepaeが効いてるのか問題です。

forcepaeは大丈夫だった

 一応、立ち上がりに、F6を押したり、eをおして、forcepaeをコマンドとして入れてみたりしましたが、効果はないけれど、起ちあがりました。きっと、Live Modeの時の設定を引き継いでいるのではないかと思います。(しかし、あとで、/etc/default/grubを見たところ、そのような記述が無いのです。こう考えると、Grub4DosがPAEについてエラーを出していたのかもしれん。)

Grub2でのブートの設定

 Ubuntu(Lubuntu)とPuppy linuxのデュアルブートです。
 ここで、

# gedit /etc/grub.d/40_custom

で、

menuentry "Puppy 5.7.1" {
      set root='(hd0,3)'
      search --no-floppy --fs-uuid --set=root 649d3544-f78a-44cc-8aa4-48b8806ddfb4
      linux /precise/vmlinuz psubdir=precise
      initrd /precise/initrd.gz
}

を下につけます。(--set=root以下のUUIDは、$ ls -l /dev/disk/by-uuid | grep sdaなどで調べてください。)
そして、grub-customizer・・・
※インストールの仕方

$ sudo add-apt-repository ppa:danielrichter2007/grub-customizer
$ sudo apt-get update
$ sudo apt-get install grub-customizer

・・・を使い、puppy linuxをメニューの上にあげ、保存、MBRにインストールとすればいいと考えるのですが。
 Advanced optionが上に行って(ブートデフォルトになって)しまいました。
 つまり、


添付ファイル: fileforGrub.png 228件 [詳細]

トップ   編集 凍結解除 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2018-03-12 (月) 14:26:43